Current category:Anti-spam

SPAMfighter Adds Thunderbird 5, 6, 7 and 8 Support

Update: Mozilla Thunderbird 9 and 10 support added – Download SPAMfighter with Mozilla Thunderbird 9 and 10 Support

Mozilla Thunderbird

The latest update to SPAMfighter Pro and Free has included the much requested Thunderbird 5, 6, 7 and 8 support.

Thunderbird is the widely used free email system from Mozilla, (Mozilla also provide the Firefox browser), then non-profit software provider and with the latest release, SPAMfighter Pro and Free now support all versions of Thunderbird except version six, which will be supported in the next release of SPAMfighter Pro.

Support for Thunderbird 5, 6 , 7 and 8, and other mail clients, shows the continued evolution of SPAMfighter Pro to protect users from spam, no matter how they consume their email.

Download SPAMfighter with Thunderbird 5, 6, 7 and 8 support

GD Star Rating
a WordPress rating system

About Justin Bellinger

Justin is an experienced software professional, having worked in software and software security for nearly 20 years. Justin is VP of Security Products at SPAMfighter.
This entry was posted in Anti-spam and tagged , , , . Bookmark the permalink.

34 Comments

  1. Thunderbird 6 isn’t working with SpamFighter yet… eta?

  2. Falkner says:

    Hi Chris,

    1-2 weeks. I will keep you posted

  3. jim says:

    Have installed & de-installed latest Spamfighter 4 times and STILL no toolbar!

  4. Is Firefox 6.0 supported? Thanks.

  5. jim says:

    I would dearly love to have the Spamfighter toolbar please

  6. Jave says:

    Looking forward to Thunderbird 6 support. :-) Keep up the good work.

  7. Hi Jim,

    Thanks for your question. I’ll recommend you to contact our support: http://www.spamfighter.com/Support_Default.asp – I’m sure that they can fix your problem :)

    Patrick T. Rasmussen
    Marketing
    SPAMfighter.com

  8. Falkner says:

    Hi Chris,

    Thunderbird 6.0 is now supported by SPAMfighter: http://www.spamfighter.com/Download_Download.asp

  9. joop says:

    `still does not work with thunderbird 6.01. I do not see toolbar….

  10. joop says:

    still does not work with thunderbird 6.01
    no toolbar…….

  11. Hi Joop,

    Thanks for your question.

    Did you remember to download the newest version from our website: http://www.spamfighter.com/Download_Download.asp ?

    Looking forward to hear from you

    Patrick T. Rasmussen
    SPAMfighter

  12. joop says:

    yes I downloaded the newest version.

  13. Frederik says:

    Arh Sweet feature spamfighters!

  14. joop says:

    any suggestions?

  15. Pingback: Thunderbird support | Turkonkoloji

  16. Jave says:

    Hi,
    Spamfighter 7.3.64 working fine for me with Thunderbird 6.0.2. Thanks!
    Jave.

  17. Hi Joop

    I need you to fill out this from: http://www.spamfighter.com/Support_Default.asp – Then will our support department help you

    Patrick T. Rasmussen
    SPAMfighter.com

  18. Rod Diery says:

    So where is spamfighter for Thunderbird 6. I to 2 weeks about 3 weeks ago.

  19. Jave says:

    Hi,
    Now there’s Thunderbird 7 to support!!! Three major upgrades of Mozilla Thunderbird in as many months. Keep up the good work for support.
    Jave.

  20. Falkner says:

    Hi Jave

    Support for Thunderbird 7 should be ready to rock & roll: http://www.spamfighter.com/Download_Download.asp

  21. Jave says:

    Hi,
    Thunderbird 7.0.1 working well for me with SPAMFighter 7.3.66 on Win7 x64 Ultimate.
    Jave.

  22. Jo says:

    How about support for Thunderbird 7.01? My Spamfighter Pro hasn’t worked since 28th September and I am finding this frustrating.
    Help please, anyone?

  23. Jo says:

    PS I need the link for Pro version not the free one. Please contact me ASAP

  24. Hi Jo

    Did you download the latest version of SPAMfighter? http://www.spamfighter.com/Download_Download.asp

    If you did that already please contact our support department: http://www.spamfighter.com/Support_Default.asp

    I’m sure that they can help you

    Patrick T. Rasmussen
    SPAMfighter.com

  25. remi says:

    Hi

    I just purchased Spamfighter but the last release of Thnderbird has disabled my Spamfighter Toolbar: is there a Spamfighter toolbar compatible with Thunderbird 8.0 plz ?

    thanks
    Remi

  26. Jave says:

    Hi,
    Thunderbird 8.0 working well for me with SPAMFighter 7.3.70 on Win7 x64 Ultimate. (I did however have to go into “Add-Ons” and “re-enable” SPAMFighter after installation.)
    Jave.

  27. Hi Remi

    We’ve just released an update to SPAMfighter, that supports Thunderbird 8

    You can download the latest version here:
    http://www.spamfighter.com/thunderbird_spam_filter.asp

  28. Awesome, thanks for the updates Patrick!

    SPAMfighter working with Thunderbird 8 for me :)

  29. Digitaldude says:

    Spamfighter 7.3.78 FINALLY seems to work with T-bird 8.

    HOWEVER, it is STILL causing a T-bird memory leak. For the longest time I thought the problem of T-bird staying in memory after being closed was a t-bird issue. BUT I discovered the problem went away when Spamfighter did not remain compatible with T-Bird, and has now returned when in version 7.3.78.

    Please advise. We have been patient in your quest to get back in synch with T-bird development.

  30. Hi Digitaldude,

    Thanks for your question, i’ve never heard about that issue before, but I need you to write to our tech support department and tell them about the memory issue.

    You can contact them through this form: http://www.spamfighter.com/Support_Default.asp

  31. Patrick T. Rasmussen says:

    FYI: We’ve released a version that supports Mozilla Thunderbird 9. (Thank you Mozilla for releasing major updates all the time :) )

  32. Thunderbird 6.0 is now supported by SPAMfighter – Finally!

    Great stuff SpamFighter!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>